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Excel is a spreadsheet program that allows storing a huge amount of 

data in tables, performing mathematical operations and statistical 

analyses on them, and creating graphs on them. 

 

1.1- Run the program 

To run Excel, follow these steps: 

From the taskbar and from the Start menu located on the left of the bar 

located at the bottom of the desktop, choose All Programs. A list of 

programs will appear. Microsoft Office is selected, and from the submenu, 

Microsoft Excel is selected or clicked. A blank worksheet will then be 

created automatically containing a number of pages, as shown in the 

figure. 
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Title bar containing the title of the open workbook. When open a new 

workbook, Excel gives it the name Book1. When save the workbook with 

a new name, this new name appears on the title bar. This bar contains 

icons for closing, minimizing, and maximizing the window. It also 

contains a quick boot toolbar, whose commands are used frequently 

during work. A menu bar such as File, Home, Insert, Page Layout, 

Formula, Date, …. and there is another bar which is the Command bar 

which contains separate groups each group contains a type of command. 

There is a very important bar in the Excel workbook, which is the 

formula bar, which shows the contents of the active cell, whether there is 

a mathematical formula or any other data, as we can see in the figure.   

 
There is also a Status bar that appears at the bottom of the screen and 

shows the workbook display methods in addition to brief information 

about the current workbook status. 

 

 

 

A worksheet consists of a set of 

1-  Rows, which are a set of cells arranged horizontally in a table and 

are referred to by numbers.  

2- Columns are a group of cells arranged vertically in a table and are 

indicated by letters.  

3- Cell is the intersection of a row and a column and has an address 

called a cell reference, which consists of a letter and a number. The 

letter identifies the column and the number identifies the row. 
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For example, this cell is located at the intersection of the letter C and the 

number four. read it from the cell reference and C4 reads it. When click 

on any other cell in the worksheet, will read it from the cell reference. 

When a cell is located in column B and row 12, the cell reference will read 

B12. 

➢ Cell range 

Range is the range that indicates the distance between two 

points and it is of three types: 

1- Horizontal range that includes consecutive cells 

horizontally within a single row as shown in the below 

figure, where the range B6:H6. 

  

 
 

2- Vertical range that includes consecutive cells vertically 

within a single column as shown in the below figure, where 

the range D2:D8. 
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3- Horizontal and vertical range, which includes 

consecutive cells vertically and horizontally at the same 

time, as in the below figure, where the range A1:E3. 

 

 

 

When you open a new workbook, click on the File menu, then choose the 

New option. Then, the New Workbook dialog box will appear, as shown 

in the figure. 

 

Then from the available templates, choose an empty workbook template. 
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After completing all the work on the worksheet, the saving process is 

done as follows: Go to the File menu, then click Save. A dialog window 

appears with the name Save As. Then, the saving location and file type 

are chosen. 

 

Workbooks created using Excel 2010 can be opened in earlier versions of 

Excel, taking into consideration the loss of some of the specifications 

specific to Excel 2010. To save the workbook for use in earlier versions of 

Excel, follow the steps below: 

Click on the File menu and choose Safe As option, a drop-down list will 

appear as shown in the figure below. At the bottom of this list there are 

two bars, one for the name and the other for the type of saving. The bar 

for the type of saving is selected, and by clicking on it once a list of the 

types of saving will appear. For example, choose Excel 97 - 2003 

Workbook and then select the box at the bottom of the list titled Save. 

The file is then saved in the type that was selected. 
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To enter data into a worksheet in an Excel workbook, place the cursor in 

the cell into which want to enter data by clicking in that cell or using the 

arrows on the keyboard. A box appears around the cell, indicating that 

this cell is the active cell. Then enter the data or mathematical formulas 

into it, then press the Enter key. The data inside the cells can be modified 

by double-clicking inside the cell. Then the data inside this cell can be 

modified as required. 

 

When executing any command on a cell or group of cells, this cell must be 

selected according to the following cases: 

1- Select a single cell by clicking on the cell. 

2- To select a range of cells, place the mouse pointer in the cell from 

which the selection begins, then press the left mouse button and move 

in the direction as required. Continue pressing until the desired area 

is selected, as in the figure. 

 

3- To select all cells in a worksheet, click the Select All button, which is 

Ctrl + A on the keyboard. 

4- To select a specific row, place the cursor on the row number and 

the cursor will turn into a small black arrow. Then click on the 

number and this row will be selected. 
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5- The same applies when you want to specify a specific column, 

where the cursor is on the letter of that column. 

 

To insert one or more rows at a certain point in the worksheet, place the 

cursor at the beginning of the row before which we want to add a new 

row, and from the Home tab, from the Cells group, click the arrow next 

to Insert, then click Insert table Rows, as in the figure

Also, to insert a column, follow the same previous steps. 

 

 

Can be delete entire rows or columns and remove them from the 

worksheet as follows: 

The column or row that want to delete is selected from the main page and 

from the Cells group. Click on the arrow on the side of the list. A new sub-

list appears containing Delete. Choose to delete the selected item, 

whether it is a column or a row. 
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To modify the cell dimensions (length or width) to fit the data within 

these cells. From the main menu and from the cells group, choose Format 

and click on the arrow next to this option. A drop-down list will appear 

containing many options such as row height, column width, etc. Choose 

one of these and a new message will appear in which you specify the 

required dimensions. 

 

When the data is wider than the width and length of the page shown on 

the screen, the row and column headings can be frozen when browsing 

the distant rows or columns. 

First, place the cursor in the cell from which you want to start freezing. 

From the menu bar, go to the View menu, and from the Window group, 

choose Freeze Pans, and from the arrow below the option, click to 

display a drop-down list containing three options. The first option is to 

freeze the page, the second option is to freeze the top row, and the third 

option is to freeze the first column. Choose one of these three options 

according to what is required to be implemented. 
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The copying process is done by selecting the cells you want to copy and 

then right-clicking the mouse. A drop-down menu will appear, and you 

can choose Copy. The second way is to go to the main page, Home, and 

from the Clipboard group, click Copy. A dotted frame will appear around 

the cells you want to copy. Then, move the cursor to the location you 

want to copy to. From the right mouse button, a drop-down menu will 

appear, and you can click Paste. Or by going to Home, and from the 

Clipboard group, choose Paste, and the copy and paste process is 

completed. In this case, you will have two copies of the data: the original, 

primary copy, and the second copy, which was copied to another location 

or in another place. In the case of cut or move, the same previous 

procedures are followed, but cut is chosen instead of copy, and the data is 

transferred to another location and pasted in any required place. In this 

case, we will have one copy of the data, which is the same as the original 

data, as soon as it is transferred from one location to another, so we will 

have only one copy. 

 

One of the good features of the pasting process is that there are several 

options for the pasting process through the button in the pasting icon or 

by clicking the right mouse button on the cell in which you want to paste. 

Then a sub-menu appears containing the pasting options as in the figure. 
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The automatic filling feature is very excellent as it saves time and effort in 

many office, arithmetic and logical operations, as through this feature it is 

possible to obtain results for a very large and huge amount of data in a 

very short time. 

This process is done by selecting the cell that contains specific data and it 

was required to copy the formatting in this cell to a number of cells. Once 

you click on the cell that contains the required formatting, a small square 

will appear in the lower right corner of the box surrounding the cell. Once 

you place the cursor on this small square and click on it with the left 

mouse button while continuing to press and drag on the cells in which 

you want to copy that formatting, and when you finish with the required 

cells and reach the last required cell, release the left mouse button and 

thus this formatting will be copied to all of these cells. 
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When you open an Excel workbook, it gives you three worksheets by 

default and tabs at the bottom of the workbook called Sheet 1, Sheet 2, 

Sheet 3. In the case of inserting a new worksheet, there is an option at the 

bottom of the workbook with a plus sign ( + ). Click on it with the left 

mouse button, then it will add a new sheet. As for deleting a specific page 

from the workbook, then put the mouse pointer on the name of that sheet 

and by clicking with the right mouse button, a drop-down list will appear 

containing Delete. Then, choose Delete and the sheet will be canceled. 

Any page of the document or workbook can be named with any name 

according to the user and according to the names of the pages that are 

required to be named, by placing the cursor on the name of the page and 

clicking with the right mouse button. A drop-down menu will appear 

containing options including the option to Rename. Just by clicking on 

rename, the old name will be determined and then you can write the 

name that you want to name the page with. 

 

The mathematical formula may contain numbers or mathematical 

operations in data analysis in Excel. In the following table, notice some 

mathematical formulas used to complete the mathematical operations. 
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In arithmetic operations, the order must be taken into account, i.e. 

multiplication and division precede addition and subtraction. can be 

written any mathematical formula in any cell of Excel that you want to 

display a specific result in that cell. This function is usually preceded by 

an equal sign and the mathematical terms are surrounded by 

parentheses. The mathematical formula inside the bracket is performed 

before the operation outside the bracket. 

A formula is an equation that performs a calculation. Excel can execute 

formulas that add, subtract, multiply, and divide like a calculator. 

• To creates a simple formula in Excel: 

1- Select the cell where the answer will appear (B4, for example). 

 

 

 

2- Type the equals sign (=). 

3- Type in the formula you want Excel to calculate (75/20, for 

example). 

4- Press Enter. The formula will be calculated, and the value will be 

displayed in the cell. 
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If the result of a formula is too large to be displayed in a cell, it may 

appear as pound signs (#######) instead of a value. This means the 

column is not wide enough to display the cell content. Increase the 

column width to show the cell content. 

• To creates a formula using cell references: 

1- Select the cell where the answer will appear (B4, for example). 

 

 

 

2- Type the equals sign (=).  

3-  Type the cell address that contains the first number in the equation 

(B2, for example). 

4- Type the operator you need for your formula. For example, type the 

divide sign (/). 

5- Type the cell address that contains the second number in the 

equation (B3, for example). 

 

 

 

6- Press Enter. The formula will be calculated, and the value will be 

displayed in the cell. 
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If you change a value in either B2 or B3, the total will automatically 

recalculate. 

 

Many mathematical operations and formulas are performed in Excel, 

and among these formulas are the Sum, Average determining the 

Maximum value, and determining the Minimum value. This is done 

through the Home menu, and by going to the Editing group, the Sigma 

option (∑) is selected via the small arrow located below this option. By 

left-clicking on this arrow, a drop-down list will appear containing the 

required formulas. Then, the formula that is required to be performed 

on the selected cell or cells is selected. 

 

To take advantage of these features in Excel, there is some data as 

shown in the figure below: There are ways to perform mathematical 

operations on this data. For example, when performing the addition 

operation for all these numbers in the cells shown in the figure, after 

selecting the cell in which you want to put the result 

1- An equal sign is placed in the cell, then the phrase Sum is written. 

Then the contents of the cells that need to be calculated are written 

in this cell, or selecting these and by pressing Enter, the process of 

calculating the sum of these cells will be done directly. 
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2- The second method is to only select the cell in which the result is, 

and by going to the main page, Home, to the Editing group, and to 

the list of mathematical formulas, which are sum, average, 

maximum value, and minimum value, you only click on the Sum 

option, pressing Enter,  and then the sum of the numbers in the 

selected cells will appear directly. 

And also, for the rest of the existing formulas such as the Average or 

finding the Maximum value or finding the Minimum value, etc., the 

same as the previous processor. All that is required is to click or 

choose the desired option to perform the calculation on the contents of 

the selected cells. 

• Editing a Formula 

The equation can be modified either from the equation bar or from 

the cell that contains the equation. We click in this cell and the 

equation appears on the equation bar. We make the required 

modifications and when we finish that, press the Enter key or double-

click the cell and the required modified equation appears. 

• Copy formatting 

If there are several columns of data as in the figure below, and you want 

to sum this data as in the first column on the left side, this is done by 
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clicking on the small square located in the lower right side of the box 

surrounding the cell that contains the result of the first column, and by 

dragging it to the rest of the cells adjacent to it, which will contain the 

sum result of the columns whose data you want to sum, then the 

formatting in the cell will be copied to the rest of the cells as shown in the 

figure 

 
 

 

You can insert a specific image or shape from the computer, the Internet, 

or an external hard drive and paste it into an Excel document. This is 

done by selecting the cell in which you want to paste the shape. By going 

to the Insert menu and from the Illustrations group, choose Picture. A 

list of options will appear showing many files containing images found on 

the computer. If the required image is from the Internet, select Online. 

The process is shown as in the figure below. 
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Sometimes it is required to protect the page or document in order to 

preserve the existing data from any change or tampering by any user. 

Therefore, there is an option in a Excel document that protects the sheet 

work, bookwork. It can be used by the person who created this document, 

according to the following method.  

After completing the work, go to the Review menu and then go to the 

Protect group, which contains several options. You can choose the 

desired option, such as Protect Sheet, and thus the sheet becomes 

protected from any changes that may occur to it by other users.  

 

 

One of the important features in Excel is the process of drawing data, the 

purpose of which is to know the behavior of a specific physical condition 

whose data has been collected and placed in an Excel document. This is 

done by selecting this data and going to the Insert menu, then going to 

the charts group and choosing the appropriate chart. A new drop-down 

list will then appear containing a group of chart types from which the 

appropriate drawing or format can be chosen. 
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